1С 8.3 : Подсчет итогов динамического списка (медленный вариант при большом объеме данных)

Автор: | 23.11.2017

Как подсчитать итоги динамического списка (медленный вариант при большом объеме данных)

1С 8.3 : Подсчет итогов динамического списка (медленный вариант при большом объеме данных): 3 комментария

  1. Николай

    Я делал так!

    Процедура ОбновлениеОтображения()

    Если НЕ ЭлементыФормы.ДействияФормы.Кнопки.ВыводитьИтоги.Пометка Тогда
    ЭлементыФормы.ДокументСписок.Колонки.СуммаДокумента.ТекстПодвала = “”;
    Возврат;
    КонецЕсли;

    Построитель = Новый ПостроительЗапроса;
    Построитель.ИсточникДанных = Новый ОписаниеИсточникаДанных(ДокументСписок);
    Результат = Построитель.Результат.Выгрузить(); //отобранные строки типа РезультатЗапроса

    ЭлементыФормы.ДокументСписок.Колонки.СуммаДокумента.ТекстПодвала = Результат.Итог(“СуммаДокумента”);

    КонецПроцедуры

    на 5000 документах работало идеально, но потом жесть…((((
    щас гляну как отработает Ваш код на 6741 документов.

  2. Николай

    даже пробовал через кнопку.

    Процедура ДействияФормыВыводитьИтоги(Кнопка)

    Кнопка.Пометка = НЕ Кнопка.Пометка;
    ОбновлениеОтображения();

    КонецПроцедуры

  3. Николай

    медленный вариант при большом объеме данных!
    Это примерно сколько должно быть документов в форме списка?
    на каком количестве он уже замедляем работу?

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

4 + 3 =