Как подсчитать итоги динамического списка (медленный вариант при большом объеме данных)

 

3 комментария: 1С 8.3 : Подсчет итогов динамического списка (медленный вариант при большом объеме данных)

  • Я делал так!

    Процедура ОбновлениеОтображения()

    Если НЕ ЭлементыФормы.ДействияФормы.Кнопки.ВыводитьИтоги.Пометка Тогда
    ЭлементыФормы.ДокументСписок.Колонки.СуммаДокумента.ТекстПодвала = “”;
    Возврат;
    КонецЕсли;

    Построитель = Новый ПостроительЗапроса;
    Построитель.ИсточникДанных = Новый ОписаниеИсточникаДанных(ДокументСписок);
    Результат = Построитель.Результат.Выгрузить(); //отобранные строки типа РезультатЗапроса

    ЭлементыФормы.ДокументСписок.Колонки.СуммаДокумента.ТекстПодвала = Результат.Итог(“СуммаДокумента”);

    КонецПроцедуры

    на 5000 документах работало идеально, но потом жесть…((((
    щас гляну как отработает Ваш код на 6741 документов.

  • даже пробовал через кнопку.

    Процедура ДействияФормыВыводитьИтоги(Кнопка)

    Кнопка.Пометка = НЕ Кнопка.Пометка;
    ОбновлениеОтображения();

    КонецПроцедуры

  • медленный вариант при большом объеме данных!
    Это примерно сколько должно быть документов в форме списка?
    на каком количестве он уже замедляем работу?

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

31 + = 37

Подписаться на блог по эл. почте

Укажите свой адрес электронной почты, чтобы получать уведомления о новых записях в этом блоге.

Присоединиться к еще 5 подписчикам

Рейтинг@Mail.ru